adv

Componenti aggiuntivi essenziali per le patch Elementor Vulnerabilità critica dell’escalation dei privilegi – WP Tavern

Componenti aggiuntivi essenziali per Elementorun plugin con più di un milione di installazioni attive, ha corretto una vulnerabilità di escalation dei privilegi non autenticati nella versione 5.7.2. La vulnerabilità è stata scoperta l’8 maggio 2023 e segnalata dal ricercatore di Patchstack Rafie Muhammad. Gli è stato assegnato un punteggio CVSS 3.1 di 9,8 (gravità critica) e non è ancora noto che sia stato sfruttato.

Muhammad ha delineato la vulnerabilità in a consulenza sulla sicurezza pubblicato oggi:

Questo plugin soffre di una vulnerabilità legata all’escalation dei privilegi non autenticati e consente a qualsiasi utente non autenticato di aumentare i propri privilegi a quelli di qualsiasi utente sul sito WordPress.

È possibile reimpostare la password di qualsiasi utente purché si conosca il suo nome utente, potendo così reimpostare la password dell’amministratore e accedere al proprio account. Questa vulnerabilità si verifica perché questa funzione di reimpostazione della password non convalida una chiave di reimpostazione della password e modifica invece direttamente la password di un determinato utente.

Gli autori del plugin hanno pubblicato la patch oggi, 11 maggio, con la seguente nota nel registro delle modifiche:

5.7.2 – 05/11/2023
Migliorato: modulo di accesso/registrazione EA per il miglioramento della sicurezza
Alcune correzioni di bug e miglioramenti minori

La vulnerabilità colpisce i siti che utilizzano le versioni da 5.4.0 a 5.7.1 di Essential Addons for Elementor. Si consiglia agli utenti di aggiornare immediatamente all’ultima versione 5.7.2 ora che è disponibile Patchstack pubblicato la prova del concetto per sfruttarlo.

Supporto
1
🛎️ Chatta con noi!
Scan the code
Ciao 👋
Hai bisogno di aiuto?