adv

WordPress 6.4.1 Risolve un bug critico di cURL/Richieste – WP Tavern

I contributori di WordPress hanno lavorato rapidamente nelle ultime 24 ore per preparare un file 6.4.1 rilascio di manutenzione Dopo un bug critico è emerso da una modifica nella libreria Requests, causando problemi con gli aggiornamenti sui server che eseguono versioni precedenti di cURL.

Le società di hosting hanno iniziato a segnalare l’impatto diffuso del bug. Tom Sommer, di una delle più grandi società di hosting danesi, ha presentato un GitHub problema delineando il modo in cui i timeout del cURL influenzavano i siti:

  • #657 interrompe i download verso https://api.wordpress.org/ e molti altri siti quando si utilizza Curl 7.29.0 (e forse altre versioni)
  • Error: RuntimeException: Failed to get url 'https://api.wordpress.org/core/version-check/1.7/?locale=en_US': cURL error 28: Operation timed out after 10000 milliseconds with 807 out of -1 bytes received.
  • Causa inoltre problemi con l’API REST in Integrità del sito con l’errore: REST API response: (http_request_failed) cURL error 28: Operation timed out after 10005 milliseconds with XXX out of XXX bytes received”
  • Impedisce inoltre gli aggiornamenti dei plugin e dei core di WordPress, praticamente tutto ciò che si basa sul gestore Curl interno di WordPress.

Il problema è diventato una priorità assoluta poiché non era chiaro come gli utenti avrebbero potuto ricevere un aggiornamento.

“Anche se risolverai questo problema adesso il problema impedisce qualsiasi futuro aggiornamento automatico alla versione 6.4.1poiché interrompe le richieste di Curl, quindi l’unico modo per aggiornare le persone sarebbe manualmente”, ha affermato Sommer. “Più aspetti, più grande diventerà il problema.”

Nexcess ha segnalato che decine di migliaia di siti sono interessati dal bug. Il problema andava oltre ciò che la maggior parte degli utenti sarebbe stata in grado di risolvere manualmente da soli, lasciando agli host il compito di capire come aggiornare i propri clienti.

“Tutti i miei siti web si sono bloccati dopo l’aggiornamento a WordPress 6.4”, ha riferito Javier Martín González. “Quelli senza aggiornamenti funzionano normalmente.”

È stato segnalato anche che il bug era la causa causando potenziali API Stripe, WP-Admin e problemi di prestazioni.

Tiffany Bridge, responsabile prodotto Liquid Web/Nexcess riassunto come è emerso questo problema:

Sembra:

  • Qualcuno segnalato un bug che ha a che fare con l’interazione tra il suo sistema di protezione dalle intrusioni e WordPress
  • Loro allora hanno inviato la propria patch a WordPress
  • Il responsabile del progetto per quell’area ha chiesto al presentatore di scrivere dei test, cosa che non ha fatto
  • Poi hanno comunque fuso le PR, nonostante la mancanza di test
  • Nel frattempo gli host dovranno annullare noi stessi tale modifica sui nostri parchi risorse in modo che i nostri clienti possano ancora avere piccole cose come aggiornamenti core e plug-in se stiamo eseguendo una versione cURL interessata. (7.29 confermato, potrebbero essercene altri)

I contributori principali di WordPress dovranno andare a fondo del modo in cui questo bug è stato consentito, tramite un’autopsia o altra discussione per evitare che ciò accada su così larga scala in futuro.

WordPress 6.4.1 aggiorna la libreria Richieste dalla versione 2.0.8 A 2.0.9. come versione hotfix per mitigare il problema. Annulla il cambiamento problematico. La versione 6.4.1 include anche correzioni per altri tre problemi separati. Aggiornamenti automatici spediti questa sera per chiunque abbia siti che supportano gli aggiornamenti automatici in background.

Supporto
1
🛎️ Chatta con noi!
Scan the code
Ciao 👋
Hai bisogno di aiuto?