adv

Vulnerabilità del plug-in di conformità GDPR di Complianz WordPress

Un popolare plugin WordPress per la conformità alla privacy con oltre 800.000 installazioni ha recentemente corretto una vulnerabilità XSS archiviata che potrebbe consentire a un utente malintenzionato di caricare script dannosi per lanciare attacchi contro i visitatori del sito.

Conformità | Plug-in WordPress per il consenso ai cookie GDPR/CCPA

Il plugin Complianz per WordPress è un potente strumento che aiuta i proprietari di siti web a rispettare le normative sulla privacy come il Regolamento generale sulla protezione dei dati (GDPR) e il California Consumer Privacy Act (CCPA).

Il plug-in gestisce molteplici aspetti della privacy dell'utente, tra cui il blocco dei cookie di terze parti, la gestione del consenso ai cookie (incluso per sottoregione) e la gestione di molteplici aspetti relativi ai banner dei cookie.

La sua versatilità e utilità possono spiegare la popolarità dello strumento che attualmente conta oltre 800.000 installazioni.

Vulnerabilità XSS memorizzata nel plug-in Complianz

È stato scoperto che il plugin Complianz WordPress presenta una vulnerabilità XSS memorizzata, un tipo di vulnerabilità che consente a un utente di caricare uno script dannoso direttamente sul server del sito web. A differenza di un XSS riflesso che richiede all'utente di un sito Web di fare clic su un collegamento, un XSS archiviato implica uno script dannoso archiviato e servito dal server del sito Web di destinazione.

La vulnerabilità risiede nelle impostazioni di amministrazione di Complianz e si presenta sotto forma di una mancanza di due funzioni di sicurezza.

1. Sanificazione ingresso
Il plugin non disponeva di una sufficiente pulizia degli input e di escape dell'output. La sanificazione dell'input è un processo standard per controllare l'input in un sito Web, ad esempio in un campo del modulo, per assicurarsi che l'input sia quello previsto, come un input di testo anziché il caricamento di uno script.

L'ufficiale La guida per sviluppatori di WordPress descrive la sanificazione dei dati COME:

“La sanificazione dell'input è il processo di protezione/pulizia/filtraggio dei dati di input. La convalida è preferibile alla sanificazione perché la convalida è più specifica. Ma quando “più specifico” non è possibile, la sanificazione è la soluzione migliore.”

2. Uscita in uscita
Il plugin non disponeva dell'Output Escaping, un processo di sicurezza che rimuove i dati indesiderati prima che vengano renderizzati per un utente.

Quanto è grave la vulnerabilità?

La vulnerabilità richiede che l'aggressore ottenga livelli di autorizzazione di amministratore o superiori per eseguire l'attacco. Questo potrebbe essere il motivo per cui a questa vulnerabilità viene assegnato un punteggio di 4,4 su 10, dove dieci rappresentano il livello di vulnerabilità più elevato.

La vulnerabilità colpisce solo tipi specifici di installazioni.

Secondo Wordfence:

“Ciò consente agli aggressori autenticati, con autorizzazioni a livello di amministratore e superiori, di iniettare script web arbitrari in pagine che verranno eseguiti ogni volta che un utente accede a una pagina iniettata.

Ciò riguarda solo le installazioni multisito e le installazioni in cui unfiltered_html è stato disabilitato.”

Aggiorna all'ultima versione

La vulnerabilità colpisce le versioni Complianz uguali o inferiori alla versione 6.5.5. Gli utenti sono incoraggiati ad aggiornare alla versione 6.5.6 o successiva.

Leggi l'avviso di Wordfence sulla vulnerabilità:

Conformità | Consenso cookie GDPR/CCPA <= 6.5.5 – Scripting cross-site archiviato (amministratore+) tramite impostazioni

Supporto
1
🛎️ Chatta con noi!
Scan the code
Ciao 👋
Hai bisogno di aiuto?